Partial Outage
Incident Report for acast
Resolved
The partial outage have been resolved and we'll keep monitoring the systems for the coming hours.
Posted about 2 months ago. Sep 29, 2017 - 13:09 CEST
Investigating
We are currently experiencing a partial outage. It's currently being investigated by our tech team. Continuous updates will be provided.
Posted about 2 months ago. Sep 29, 2017 - 11:46 CEST