Not possible to login to create
Incident Report for acast
Resolved
The issue has been resolved.
Posted over 2 years ago. Jul 15, 2015 - 15:23 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 2 years ago. Jul 15, 2015 - 09:47 CEST
Investigating
We are currently investigating this issue.
Posted over 2 years ago. Jul 15, 2015 - 09:06 CEST