Embed player not working
Incident Report for acast
Resolved
We have identified and resolved the issue with our embed player not working. Sorry for the inconvenience.
Posted about 2 years ago. Sep 18, 2015 - 08:25 CEST
Investigating
We are experiencing technical issues with our embed player at the moment. We are currently investigating what may have caused this incident. Thank you for your patience.
Posted about 2 years ago. Sep 18, 2015 - 08:05 CEST